CVE-2024-11731: Master Slider (WordPress plugin) · Cross-site Scripting
Affects Master Slider (WordPress plugin)Source CVE Database V5
Not known to be exploited · CVSS 6.4 Medium · fixed in 3.10.8 : update Master Slider (WordPress plugin) when convenient.
Data as of 26 Oct 2026, 08:11 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 20% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 3.10.8
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:NExploitation evidence
Disclosed: evidence found.
CVE published 5 Mar 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| averta Master Slider – Responsive Touch Slider | Affected
| Fixed in– |
AI-suggested
This vulnerability was partially fixed in version 3.10.8 of the Master Slider plugin. Users should upgrade to version 3.10.8 or later to benefit from the partial fix. Until fully patched, restrict contributor-level access to trusted users and review content submitted via the ms_slider shortcode for malicious input.
Description
The Master Slider – Responsive Touch Slider plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's ms_slider shortcode in all versions up to, and including, 3.10.7 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This issue was partially fixed in version 3.10.8.
References
- wordfence.com/threat-intel/vulnerabilities/id/f1dcafe1-bdba-4476-bcc7-ad844da38a01?source=cve (opens in a new tab)
- wordpress.org/plugins/master-slider/ (opens in a new tab)
- plugins.trac.wordpress.org/changeset/3288436 (opens in a new tab)
- plugins.trac.wordpress.org/browser/master-slider/tags/3.10.8/includes/msp-shortcodes.php (opens in a new tab)