CVE-2024-11888: IDer Login for WordPress · Cross-site Scripting
Affects IDer Login for WordPressSource CVE Database V5
Not known to be exploited · CVSS 6.4 Medium · fixed in 2.1 : update IDer Login for WordPress when convenient.
Data as of 26 Oct 2026, 17:16 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 28% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.1
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:NExploitation evidence
Disclosed: evidence found.
CVE published 14 Dec 2024
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| ider IDer Login for WordPress | Affected
| Fixed in– |
AI-suggested
Currently, no patched version of the plugin is publicly available despite the vendor indicating a fix in version 2.1. Users should avoid using the 'ider_login_button' shortcode or restrict contributor-level access until an official patched release is published. Monitor the vendor's communications for an official update containing the fix.
Description
The IDer Login for WordPress plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's 'ider_login_button' shortcode in all versions up to, and including, 2.1 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This affects version 2.1, but was also patched in version 2.1 - a new version was not released with the patch.
References
- wordfence.com/threat-intel/vulnerabilities/id/de602cf8-cc02-4459-aa23-5d8236048bca?source=cve (opens in a new tab)
- plugins.trac.wordpress.org/browser/ider-login/trunk/includes/IDER_Shortcodes.php (opens in a new tab)
- wordpress.org/plugins/ider-login (opens in a new tab)
- plugins.trac.wordpress.org/changeset/3279435/ider-login/trunk/includes/IDER_Shortcodes.php (opens in a new tab)