Skip to main content
VulnerabilityPublished Updated

CVE-2024-11977: kk Star Ratings (WordPress plugin) · Code Injection

Affects kk Star Ratings (WordPress plugin)Source CVE Database V5

0

Not known to be exploited · CVSS 7.3 High · fixed in 5.4.10.1 : patch kk Star Ratings (WordPress plugin) soon.

Data as of 26 Oct 2026, 14:05 UTC

CVSS 3.1 base score
7.3High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.6% chance of exploitation in 30 days – higher than 50% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 5.4.10.1
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 21 Dec 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
properfraction kk Star Ratings – Rate Post & Collect User FeedbacksAffected
  • =0
Fixed in–

AI-suggested

Upgrade the kk Star Ratings plugin to version 5.4.10.2 or later, where the vulnerability is fully patched. Versions 5.4.10.1 only partially address the issue and should not be considered fully secure. If immediate upgrade is not possible, restrict access to the plugin's functionality to trusted users as a temporary measure. Patch status is confirmed by the vendor's versioning notes; no other official advisory was provided.

Description

The The kk Star Ratings – Rate Post & Collect User Feedbacks plugin for WordPress is vulnerable to arbitrary shortcode execution in all versions up to, and including, 5.4.10. This is due to the software allowing users to execute an action that does not properly validate a value before running do_shortcode. This makes it possible for unauthenticated attackers to execute arbitrary shortcodes. Note: This vulnerability was only partially patched in version 5.4.10.1, and fully patched in 5.4.10.2

References

Community reviews

Loading reviews…