CVE-2024-13496: GamiPress (WordPress plugin) · SQL Injection
Affects GamiPress (WordPress plugin)Source CVE Database V5
Not known to be exploited · public detection template (Nuclei) · CVSS 7.5 High · fixed in 7.3.2 : patch GamiPress (WordPress plugin) soon.
Data as of 26 Oct 2026, 08:30 UTC
- EPSS
- 2.2% chance of exploitation in 30 days – higher than 82% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 7.3.2
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:NExploitation evidence
Disclosed: evidence found.
CVE published 22 Jan 2025
Detectable: evidence found.
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| rubengc GamiPress – Gamification plugin to reward points, achievements, badges & ranks in WordPress | Affected
| Fixed in– |
AI-suggested
Users of the GamiPress plugin should upgrade to version 7.3.2 or later, where this vulnerability is fixed. Since the vulnerability was previously misreported as fixed in 7.2.2, ensure the plugin version is at least 7.3.2 before considering the issue resolved. No other mitigations are specified. Patch status is confirmed fixed in version 7.3.2.
Description
The GamiPress – Gamification plugin to reward points, achievements, badges & ranks in WordPress plugin for WordPress is vulnerable to time-based SQL Injection via the ‘orderby’ parameter in all versions up to, and including, 7.3.1 due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This makes it possible for unauthenticated attackers to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database. NOTE: This vulnerability was previously published as being fixed in version 7.2.2 which was incorrect. The correct fixed version is 7.3.2.
References
- wordfence.com/threat-intel/vulnerabilities/id/ea54436c-b623-4049-af19-9995c312476e?source=cve (opens in a new tab)
- plugins.trac.wordpress.org/browser/gamipress/trunk/libraries/ct/includes/class-ct-query.php (opens in a new tab)
- plugins.trac.wordpress.org/browser/gamipress/trunk/includes/ajax-functions.php (opens in a new tab)
- wordpress.org/plugins/gamipress/ (opens in a new tab)
- plugins.trac.wordpress.org/changeset/3226227/ (opens in a new tab)
- abrahack.com/posts/gamipress-sqli/ (opens in a new tab)