Skip to main content
VulnerabilityPublished Updated

CVE-2024-1852: WP-Members Membership Plugin · Cross-site Scripting

Affects WP-Members Membership PluginSource CVE Database V5

0

Not known to be exploited · CVSS 7.2 High · fixed in 3.4.9.3 : patch WP-Members Membership Plugin soon.

Data as of 26 Oct 2026, 15:59 UTC

CVSS 3.1 base score
7.2High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.6% chance of exploitation in 30 days – higher than 51% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 3.4.9.3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 9 Apr 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
cbutlerjr WP-Members Membership PluginAffected
  • =0
Fixed in–

AI-suggested

Users of the WP-Members Membership Plugin should upgrade to version 3.4.9.3 or later, where the vulnerability is fully patched. The partial fix in version 3.4.9.2 does not fully mitigate the issue. No other mitigations are indicated by the vendor advisory. Patch status is confirmed by the plugin version history and advisory details.

Description

The WP-Members Membership Plugin plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the X-Forwarded-For header in all versions up to, and including, 3.4.9.2 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page which is the edit users page. This vulnerability was partially patched in version 3.4.9.2, and was fully patched in 3.4.9.3.

References

Community reviews

Loading reviews…