Skip to main content
VulnerabilityPublished Updated

CVE-2024-21536: http-proxy-middleware · Denial of Service

Affects http-proxy-middlewareSource CVE Database V5

0

Public exploit available · CVSS 8.7 High : upgrade to 3.0.3 or 2.0.7 as a priority.

Data as of 26 Oct 2026, 17:16 UTC

CVSS 4.0 base score
8.7High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
1.0% chance of exploitation in 30 days – higher than 63% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
CISA SSVC
Exploitation
Proof of concept is public or traded
Automatable
Attackers can reliably automate steps 1–4 of the kill chain
Technical impact
Limited control over the software or limited information exposure

CISA SSVC assessment, 2024-10-21.

Patch
Available – fixed in 3.0.3, 2.0.7
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N/E:P

Exploitation evidence

t = 0 is the CVE’s publication on cve.org

  1. Disclosed: evidence found.

    CVE published 19 Oct 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: evidence found.

    CISA SSVC: proof of concept public

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

Timeline

  1. CVE ID reserved

    by Snyk

    , 302 days before disclosure

  2. CVE published

    on cve.org

    , t = 0

  3. CISA SSVC assessment

    proof of concept public

    , 2 days after disclosure

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CISA SSVC, the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade http-proxy-middleware to 3.0.3 or 2.0.7.

Affected software

ProductAffectedFixed in
http-proxy-middlewareAffected
  • >=3.0.0 <3.0.3
Fixed in
  • 3.0.3
http-proxy-middlewareAffected
  • <2.0.7
Fixed in
  • 2.0.7
org.webjars.npm:http-proxy-middlewareAffected
  • All versions
Fixed in–

Description

Versions of the package http-proxy-middleware before 2.0.7, from 3.0.0 and before 3.0.3 are vulnerable to Denial of Service (DoS) due to an UnhandledPromiseRejection error thrown by micromatch. An attacker could kill the Node.js process and crash the server by making requests to certain paths.

References

Community reviews

Loading reviews…