Skip to main content
CVE-2024-22257VulnerabilityPublished Updated

CVE-2024-22257: Possible Broken Access Control in Spring Security With Direct Use of AuthenticatedVoter

Affects Spring SecuritySource CVE Database V5

0

Not known to be exploited · CVSS 8.2 High · fixed in 6.2.3 : patch Spring Security soon.

Data as of 26 Oct 2026, 06:26 UTC

CVSS 3.1 base score
8.2High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.9% chance of exploitation in 30 days – higher than 61% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 6.2.3, 6.1.8, 6.0.9 +2
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 18 Mar 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
Mavenorg.springframework.security/spring-security-corepkg:maven/org.springframework.security/spring-security-coreOther threatsAffected
  • <5.7.12
  • <5.8.11
  • <6.0.9
  • <6.1.8
  • <6.2.3
Fixed in
  • 5.7.12
  • 5.8.11
  • 6.0.9
  • 6.1.8
  • 6.2.3

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

If you cannot patch yet, avoid directly using AuthenticatedVoter#vote with a null Authentication parameter in application code to prevent broken access control.

Description

In Spring Security, versions 5.7.x prior to 5.7.12, 5.8.x prior to 5.8.11, versions 6.0.x prior to 6.0.9, versions 6.1.x prior to 6.1.8, versions 6.2.x prior to 6.2.3, an application is possible vulnerable to broken access control when it directly uses the AuthenticatedVoter#vote passing a null Authentication parameter.

References

Community reviews

Loading reviews…