Skip to main content
VulnerabilityPublished Updated

CVE-2024-22365: linux-pam · Improper Control of a Resource Through its Lifetime

Affects linux-pamSource CVE Database V5

0

Not known to be exploited · CVSS 5.5 Medium : upgrade to 1.6.0 when convenient.

Data as of 26 Oct 2026, 17:16 UTC

CVSS 3.1 base score
5.5Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 39% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.6.0
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 6 Feb 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade linux-pam/linux-pam to 1.6.0.

Affected software

ProductAffectedFixed in
GitHublinux-pam/linux-pampkg:github/linux-pam/linux-pamOther threatsAffected
  • <1.6.0
Fixed in
  • 1.6.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

If you cannot patch yet, restrict local access to trusted users only and monitor for suspicious use of mkfifo or abnormal login failures related to PAM.

Description

linux-pam (aka Linux PAM) before 1.6.0 allows attackers to cause a denial of service (blocked login process) via mkfifo because the openat call (for protect_dir) lacks O_DIRECTORY.

References

Community reviews

Loading reviews…