CVE-2024-2279: GitLab · Cross-site Scripting
Affects GitLabSource GCVE Database
Not known to be exploited · CVSS 8.7 High : upgrade to 16.10.2 or 16.9.4 soon.
Data as of 27 Oct 2026, 00:52 UTC
- Patch
- Available – fixed in 16.10.2, 16.9.4
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:NExploitation evidence
Disclosed: evidence found.
CVE published 12 Apr 2024
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade GitLab to 16.10.2 or 16.9.4.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| GitLab GitLab | Affected
| Fixed in
|
AI-suggested
The vulnerability affects specific GitLab versions and has been addressed in versions 16.8.7, 16.9.4, and 16.10.2 or later. Users should upgrade to these fixed versions to remediate the issue. Since this is not a cloud service, remediation requires applying the official patches or upgrading the affected GitLab installations. No alternative mitigations or workarounds are indicated in the available data.
Description
A stored cross-site scripting (XSS) vulnerability exists in GitLab CE/EE versions 16.7 through 16.8.6, 16.9 up to but not including 16.9.4, and 16.10 up to but not including 16.10.2. The flaw occurs in the autocomplete feature for issue references, where a crafted payload can be stored and executed, potentially allowing attackers to perform arbitrary actions on behalf of authenticated users.