Skip to main content
VulnerabilityPublished Updated

CVE-2024-23172: MediaWiki · Cross-site Scripting

Source CVE Database V5

0

Not known to be exploited · CVSS 5.4 Medium · fixed in 1.40.2 : update affected systems when convenient.

Data as of 26 Oct 2026, 17:16 UTC

CVSS 3.1 base score
5.4Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 40% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.40.2, 1.39.6, 1.35.14
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 12 Jan 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade mediawiki/extensions/CheckUser to 1.40.2, 1.39.6 or 1.35.14.

Affected software

ProductAffectedFixed in
GitHubmediawiki/extensions/CheckUserpkg:github/mediawiki/extensions/CheckUserOther threatsAffected
  • <1.35.14
  • >=1.36.0 <1.39.6
  • >=1.40.0 <1.40.2
Fixed in
  • 1.35.14
  • 1.39.6
  • 1.40.2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

To mitigate CVE-2024-23172, organizations should promptly update the CheckUser extension to the fixed versions: 1.35.14 or later, 1.39.6 or later, and 1.40.2 or later. If immediate patching is not feasible, administrators should restrict access to the SpecialCheckUserLog feature to the minimum necessary set of trusted users and implement strict Content Security Policy (CSP) headers to limit the execution of injected scripts. Additionally, review and sanitize all user-generated content and message definitions rigorously. Employ web application firewalls (WAFs) with rules targeting XSS payloads specific to MediaWiki patterns. Conduct regular security audits and user activity monitoring to detect anomalous behavior indicative of exploitation attempts. Educate users about phishing and social engineering risks that could facilitate exploitation. Finally, maintain comprehensive logging and incident response plans to quickly identify and remediate any successful attacks.

Description

An issue was discovered in the CheckUser extension in MediaWiki before 1.35.14, 1.36.x through 1.39.x before 1.39.6, and 1.40.x before 1.40.2. XSS can occur via message definitions.e.g., in SpecialCheckUserLog.

References

Community reviews

Loading reviews…