CVE-2024-23176: MediaWiki MassMessage · XSS or 'Cross-site Scripting'
Affects MediaWiki MassMessageSource CVE Database V5
Not known to be exploited · CVSS 5.4 Medium : upgrade to 1.40.2 when convenient.
Data as of 30 Oct 2026, 06:59 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 14% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.40.2
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:NExploitation evidence
Disclosed: evidence found.
CVE published 14 Sep 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade MediaWiki MassMessage to 1.40.2.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| MediaWikiMassMessage | Affected
| Fixed in
|
AI-suggested
Upgrade MediaWiki MassMessage extension to version 1.40.2 or later where this vulnerability is fixed. No other mitigation or temporary workaround is indicated in the provided data.
Description
An issue was discovered in the MassMessage extension in MediaWiki before 1.40.2. For a Special:MassMessage?uselang=x-xss URL, the i18n key massmessage-form-page-help allows XSS.