CVE-2024-23178: MediaWiki · Cross-site Scripting
Source CVE Database V5
Not known to be exploited · CVSS 5.4 Medium · fixed in 1.40.2 : update affected systems when convenient.
Data as of 26 Oct 2026, 17:16 UTC
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 34% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.40.2
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:NExploitation evidence
Disclosed: evidence found.
CVE published 12 Jan 2024
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| n/a n/a | Affected
| Fixed in
|
AI-suggested
- Upgrade MediaWiki installations to version 1.40.2 or later, where the Phonos extension vulnerability has been addressed.
- If immediate upgrade is not feasible, implement strict input validation and output encoding for all i18n messages, especially those related to error handling in the Phonos extension.
- Restrict privileges for users who can modify or inject i18n messages or error content to minimize the risk of malicious input.
- Employ Content Security Policy (CSP) headers to limit the execution of unauthorized scripts in the MediaWiki environment.
- Conduct regular security audits and code reviews focusing on extensions and custom scripts that handle user-generated or localized content.
- Educate users about the risks of interacting with untrusted links or messages within the MediaWiki platform to reduce the likelihood of successful social engineering attacks.
- Monitor logs for unusual activity related to the Phonos extension or unexpected script execution attempts.
Description
An issue was discovered in the Phonos extension in MediaWiki before 1.40.2. PhonosButton.js allows i18n-based XSS via the phonos-purge-needed-error message.