Skip to main content
CVE-2024-23307VulnerabilityPublished Updated

CVE-2024-23307: Linux kernel · Integer Overflow or Wraparound

Affects Linux kernelSource CVE Database V5

0

Not known to be exploited · CVSS 4.4 Medium : upgrade to v6.8-rc1 when convenient.

Data as of 25 Oct 2026, 19:02 UTC

CVSS 3.1 base score
4.4Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.5% chance of exploitation in 30 days – higher than 47% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in v6.8-rc1
CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 25 Jan 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.

What to do

Upgrade Linux kernel to v6.8-rc1.

Affected software

ProductAffectedFixed in
LinuxLinux kernelAffected
  • >=4.1-rc1 <6.8-rc1
Fixed in
  • v6.8-rc1
Linuxlinux/kernelpkg:rpm/linux/kernelOther threatsAffected
  • =4.1-rc1
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

If you cannot patch yet, restricting access to systems requiring high privileges and limiting network exposure may reduce risk.

Description

Integer Overflow or Wraparound vulnerability in Linux Linux kernel kernel on Linux, x86, ARM (md, raid, raid5 modules) allows Forced Integer Overflow.

References

Community reviews

Loading reviews…