CVE-2024-23730: The OpenAPI and ChatGPT plugin loaders in LlamaHub (aka llama-hub) before 0.0.67 allow attackers to
Source CVE Database V5
Not known to be exploited · CVSS 9.8 Critical : upgrade to 0.0.67 as a priority.
Data as of 26 Oct 2026, 13:47 UTC
- EPSS
- 1.2% chance of exploitation in 30 days – higher than 68% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 0.0.67
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 21 Jan 2024
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade llama-hub to 0.0.67.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
npmllama-hubpkg:npm/llama-hubOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
- Immediate upgrade: Organizations should upgrade LlamaHub to version 0.0.67 or later, where the vulnerability is patched by using safe_load for YAML parsing.
- Input validation: Implement strict validation and sanitization of all YAML inputs, especially plugin descriptors and configuration files, to ensure they originate from trusted sources.
- Network segmentation: Restrict network access to systems running LlamaHub plugin loaders to trusted internal networks or VPNs to reduce exposure.
- Monitoring and detection: Deploy monitoring solutions to detect anomalous behavior indicative of code execution attempts, such as unexpected process spawning or network connections from AI service hosts.
- Least privilege: Run LlamaHub services with the minimum necessary privileges to limit the impact of a potential compromise.
- Incident response readiness: Prepare incident response plans specifically for AI platform compromises, including forensic capabilities to analyze YAML inputs and plugin activity.
- Vendor engagement: Engage with LlamaHub maintainers or community for updates and security advisories to stay informed about further patches or mitigations.
Description
The OpenAPI and ChatGPT plugin loaders in LlamaHub (aka llama-hub) before 0.0.67 allow attackers to execute arbitrary code because safe_load is not used for YAML.