Skip to main content
VulnerabilityPublished Updated

CVE-2024-24749: geoserver · Path Traversal

Affects geoserverSource GCVE Database

0
Compare

Not known to be exploited · CVSS 7.5 High : upgrade to 2.24.3 or 2.23.5 soon.

Data as of 2 Nov 2026, 16:20 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (GitHub_M)CVSS 3.17.5
Patch
Available – fixed in 2.24.3, 2.23.5
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 1 Jul 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2 Nov 2026.

What to do

Upgrade org.geoserver/geoserver to 2.24.3 or 2.23.5.

Affected software

ProductAffectedFixed in
Mavenorg.geoserver/geoserverpkg:maven/org.geoserver/geoserverOther threatsAffected
  • <2.23.5
  • >=2.24.0 <2.24.3
Fixed in
  • 2.23.5
  • 2.24.3

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Apply the official patches by upgrading GeoServer to version 2.23.5 or 2.24.3, which contain fixes for this vulnerability. If patching is not immediately possible, consider the documented workarounds: deploy GeoServer on a Linux environment instead of Windows; use Jetty as the application server instead of Apache Tomcat; or disable anonymous access to the embedded GeoWebCache administration and status pages. These mitigations reduce the risk of exploitation. Note that production environments typically use external data directories, which reduces the risk of privilege escalation.

Description

CVE-2024-24749 is a path traversal vulnerability in GeoServer versions prior to 2.23.5 and between 2.24.0 and 2.24.3 when deployed on Windows with Apache Tomcat. It allows reading arbitrary classpath resources via the GeoWebCache ByteStreamController. If the embedded data directory in the WAR file is used, this may lead to privilege escalation. Production environments typically use external data directories, reducing risk. Versions 2.23.5 and 2.24.3 include patches for this issue.

References

Community reviews

Loading reviews…