CVE-2024-25841: Cross-site Scripting
Source CVE Database V5
Not known to be exploited · CVSS 5.9 Medium · fixed in 4.1.26 : update affected systems when convenient.
Data as of 26 Oct 2026, 12:54 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 32% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 4.1.26
CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:LExploitation evidence
Disclosed: evidence found.
CVE published 27 Feb 2024
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
AI-suggested
To mitigate CVE-2024-25841, organizations should immediately upgrade the 'So Flexibilite' module to version 4.1.26 or later, where the vulnerability is patched. If you cannot patch yet, implement strict input validation and sanitization on all user-supplied data fields within the module to prevent script injection. Deploy a robust Content Security Policy (CSP) to restrict the execution of unauthorized scripts. Monitor web server logs and application behavior for unusual or suspicious activity indicative of XSS attempts. Educate developers and administrators about secure coding practices to avoid similar vulnerabilities. Additionally, consider using web application firewalls (WAFs) configured to detect and block XSS payloads targeting PrestaShop modules. Regularly audit and test the e-commerce platform for security weaknesses to proactively identify and remediate vulnerabilities.
Description
In the module "So Flexibilite" (soflexibilite) from Common-Services for PrestaShop < 4.1.26, a guest (authenticated customer) can perform Cross Site Scripting (XSS) injection.