Skip to main content
VulnerabilityPublished Updated

CVE-2024-26699: Linux kernel · drm/amd/display: Fix array-index-out-of-bounds in dcn35_clkmgr

Affects Linux kernelSource GCVE Database

0

Not known to be exploited · CVSS 7.8 High : upgrade to 6.8.0-2002.2 soon.

Data as of 26 Oct 2026, 17:16 UTC

CVSS 3.1 base score
7.8High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 12% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 6.8.0-2002.2
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 3 Apr 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade the Ubuntu linux-raspi-realtime package to 6.8.0-2002.2.

Affected software

ProductAffectedFixed in
Ubuntu Pro Realtime 24.04 LTSlinux-raspi-realtimepkg:deb/ubuntu/linux-raspi-realtime?arch=source&distro=realtime/nobleOther threatsAffected
  • <6.8.0-2002.2
Fixed in
  • 6.8.0-2002.2
Ubuntu 22.04 LTSlinux-allwinner-5.19pkg:deb/ubuntu/linux-allwinner-5.19?arch=source&distro=jammyOther threatsAffected
  • 5.19.0-1007.7~22.04.1 – 5.19.0-1015.15~22.04.1
8 affected builds
Fixed in–
Ubuntu 22.04 LTSlinux-aws-5.19pkg:deb/ubuntu/linux-aws-5.19?arch=source&distro=jammyOther threatsAffected
  • 5.19.0-1019.20~22.04.1 – 5.19.0-1029.30~22.04.1
10 affected builds
Fixed in–
Ubuntu 22.04 LTSlinux-aws-6.2pkg:deb/ubuntu/linux-aws-6.2?arch=source&distro=jammyOther threatsAffected
  • 6.2.0-1005.5~22.04.1 – 6.2.0-1018.18~22.04.1
14 affected builds
Fixed in–
Ubuntu 22.04 LTSlinux-aws-6.5pkg:deb/ubuntu/linux-aws-6.5?arch=source&distro=jammyOther threatsAffected
  • 6.5.0-1008.8~22.04.1 – 6.5.0-1024.24~22.04.1
14 affected builds
Fixed in–
Ubuntu 22.04 LTSlinux-azure-5.19pkg:deb/ubuntu/linux-azure-5.19?arch=source&distro=jammyOther threatsAffected
  • 5.19.0-1020.21~22.04.1 – 5.19.0-1027.30~22.04.2
7 affected builds
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available for this vulnerability and should be applied to affected Linux kernel versions to prevent exploitation. Users and administrators should update to fixed kernel versions at their earliest convenience.

Description

A vulnerability in the Linux kernel's AMD display driver (dcn35_clkmgr) could cause an array-index-out-of-bounds memory access. This issue arises from improper iteration over an array of dcn35 clocks, potentially leading to memory corruption. The flaw has been fixed by limiting the iteration to the array's actual size. The vulnerability affects multiple specific Linux kernel versions and has a CVSS score of 7.8. A patch is available to address this issue.

References

Community reviews

Loading reviews…