Skip to main content
VulnerabilityPublished Updated

CVE-2024-26767: Linux kernel · drm/amd/display: fixed integer types and null check locations

Affects Linux kernelSource GCVE Database

0

Not known to be exploited · CVSS 5.5 Medium : upgrade to 6.8.0-2002.2 when convenient.

Data as of 26 Oct 2026, 12:54 UTC

CVSS 3.1 base score
5.5Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 15% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 6.8.0-2002.2
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 3 Apr 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade the Ubuntu linux-raspi-realtime package to 6.8.0-2002.2.

Affected software

ProductAffectedFixed in
Ubuntu Pro Realtime 24.04 LTSlinux-raspi-realtimepkg:deb/ubuntu/linux-raspi-realtime?arch=source&distro=realtime/nobleOther threatsAffected
  • <6.8.0-2002.2
Fixed in
  • 6.8.0-2002.2
Ubuntu 22.04 LTSlinux-allwinner-5.19pkg:deb/ubuntu/linux-allwinner-5.19?arch=source&distro=jammyOther threatsAffected
  • 5.19.0-1007.7~22.04.1 – 5.19.0-1015.15~22.04.1
8 affected builds
Fixed in–
Ubuntu 22.04 LTSlinux-aws-5.19pkg:deb/ubuntu/linux-aws-5.19?arch=source&distro=jammyOther threatsAffected
  • 5.19.0-1019.20~22.04.1 – 5.19.0-1029.30~22.04.1
10 affected builds
Fixed in–
Ubuntu 22.04 LTSlinux-aws-6.2pkg:deb/ubuntu/linux-aws-6.2?arch=source&distro=jammyOther threatsAffected
  • 6.2.0-1005.5~22.04.1 – 6.2.0-1018.18~22.04.1
14 affected builds
Fixed in–
Ubuntu 22.04 LTSlinux-aws-6.5pkg:deb/ubuntu/linux-aws-6.5?arch=source&distro=jammyOther threatsAffected
  • 6.5.0-1008.8~22.04.1 – 6.5.0-1024.24~22.04.1
14 affected builds
Fixed in–
Ubuntu 22.04 LTSlinux-azure-5.19pkg:deb/ubuntu/linux-azure-5.19?arch=source&distro=jammyOther threatsAffected
  • 5.19.0-1020.21~22.04.1 – 5.19.0-1027.30~22.04.2
7 affected builds
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and should be applied to affected Linux kernel versions to resolve the issues. Users should upgrade to version 6.8.0-2002.2 or later, or the corresponding fixed versions for their distribution. No additional mitigation is indicated by the vendor advisory.

Description

A vulnerability in the Linux kernel's AMD display driver (drm/amd/display) has been resolved. The issues involved incorrect integer type comparisons in loop conditions that could cause infinite loops and pointer dereferences occurring before null checks. This could lead to denial of service due to kernel instability. The vulnerability affects multiple specific Linux kernel versions prior to 6.8.0-2002.2 and several exact older versions. A patch is available to address these issues.

References

Community reviews

Loading reviews…