Skip to main content
VulnerabilityPublished Updated

CVE-2024-26807: Linux kernel · Both cadence-quadspi ->runtime_suspend() and ->runtime_resume()

Affects Linux kernelSource GCVE Database

0

Not known to be exploited · CVSS 7.8 High : upgrade to 6.8.0-2002.2 soon.

Data as of 26 Oct 2026, 13:47 UTC

CVSS 3.1 base score
7.8High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 14% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 6.8.0-2002.2
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 4 Apr 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade the Ubuntu linux-raspi-realtime package to 6.8.0-2002.2.

Affected software

ProductAffectedFixed in
Ubuntu Pro Realtime 24.04 LTSlinux-raspi-realtimepkg:deb/ubuntu/linux-raspi-realtime?arch=source&distro=realtime/nobleOther threatsAffected
  • <6.8.0-2002.2
Fixed in
  • 6.8.0-2002.2
Ubuntu 22.04 LTSlinuxpkg:deb/ubuntu/linux?arch=source&distro=jammyOther threatsAffected
  • 5.13.0-19.19 – 5.15.0-198.208
103 affected builds
Fixed in–
Ubuntu 22.04 LTSlinux-allwinner-5.19pkg:deb/ubuntu/linux-allwinner-5.19?arch=source&distro=jammyOther threatsAffected
  • 5.19.0-1007.7~22.04.1 – 5.19.0-1015.15~22.04.1
8 affected builds
Fixed in–
Ubuntu 22.04 LTSlinux-awspkg:deb/ubuntu/linux-aws?arch=source&distro=jammyOther threatsAffected
  • 5.13.0-1005.6 – 5.15.0-1117.124
95 affected builds
Fixed in–
Ubuntu 22.04 LTSlinux-aws-5.19pkg:deb/ubuntu/linux-aws-5.19?arch=source&distro=jammyOther threatsAffected
  • 5.19.0-1019.20~22.04.1 – 5.19.0-1029.30~22.04.1
10 affected builds
Fixed in–
Ubuntu 22.04 LTSlinux-aws-6.2pkg:deb/ubuntu/linux-aws-6.2?arch=source&distro=jammyOther threatsAffected
  • 6.2.0-1005.5~22.04.1 – 6.2.0-1018.18~22.04.1
14 affected builds
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available that corrects the pointer usage in the cadence-quadspi driver's runtime suspend and resume functions. Users should update to a fixed Linux kernel version to remediate this issue. Since this is a kernel-level bug, applying the official kernel updates from the vendor or distribution is the recommended mitigation.

Description

A vulnerability in the Linux kernel's cadence-quadspi driver causes incorrect pointer usage in runtime suspend and resume functions, leading to memory corruption and potential kernel crashes. This occurs because the driver incorrectly treats the same device driver data pointer as two different structures, causing invalid memory access during device power management operations. The issue affects multiple Linux kernel versions and has been resolved in patched releases.

References

Community reviews

Loading reviews…