CVE-2024-26866: Linux kernel · spi: lpspi: Avoid potential use-after-free in probe()
Affects Linux kernelSource GCVE Database
Not known to be exploited · CVSS 5.5 Medium · fixed in 6.8.0-35.35 : update Linux kernel when convenient.
Data as of 26 Oct 2026, 13:47 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 11% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 6.8.0-35.35, 6.8.0-1009.9, 6.8.0-1008.8 +7
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 17 Apr 2024
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade to a fixed release listed under Affected software.
Patches and advisories
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 24.04 LTSlinuxpkg:deb/ubuntu/linux?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Ubuntu 24.04 LTSlinux-awspkg:deb/ubuntu/linux-aws?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Ubuntu 24.04 LTSlinux-azurepkg:deb/ubuntu/linux-azure?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Ubuntu 24.04 LTSlinux-gcppkg:deb/ubuntu/linux-gcp?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Ubuntu 24.04 LTSlinux-gkepkg:deb/ubuntu/linux-gke?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Ubuntu 24.04 LTSlinux-ibmpkg:deb/ubuntu/linux-ibm?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
An official patch is available and should be applied to affected linux-azure kernel versions. The vendor advisory confirms that the issue has been resolved. Users should update to a fixed kernel version to mitigate this vulnerability.
Description
A use-after-free vulnerability was identified and resolved in the Linux kernel's spi: lpspi driver, specifically in the probe function fsl_lpspi_probe(). The issue arises due to manual memory allocation and disposal combined with device-managed resource handling, leading to potential use of freed memory. This can cause a kernel NULL pointer dereference and denial of service. The vulnerability affects multiple versions of the linux-azure kernel prior to 6.8.0-35.35 and certain 4.11.x and 4.13.x builds. A patch is available to address this issue.
References
- ubuntu.com/security/CVE-2024-26866 (opens in a new tab)
- cve.org/CVERecord?id=CVE-2024-26866 (opens in a new tab)
- git.kernel.org/linus/2ae0ab0143fcc06190713ed81a6486ed0ad3c861 (opens in a new tab)
- git.kernel.org/stable/c/da83ed350e4604b976e94239b08d8e2e7eaee7ea (opens in a new tab)
- git.kernel.org/stable/c/1543418e82789cc383cd36d41469983c64e3fc7f (opens in a new tab)
- git.kernel.org/stable/c/996ce839606afd0fef91355627868022aa73eb68 (opens in a new tab)
- git.kernel.org/stable/c/2ae0ab0143fcc06190713ed81a6486ed0ad3c861 (opens in a new tab)
- ubuntu.com/security/notices/USN-6816-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-6817-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-6817-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-6817-3 (opens in a new tab)
- ubuntu.com/security/notices/USN-6878-1 (opens in a new tab)