CVE-2024-26954: Linux kernel · ksmbd: fix slab-out-of-bounds in smb_strndup_from_utf16()
Affects Linux kernelSource GCVE Database
Not known to be exploited · CVSS 8.1 High · fixed in 6.8.0-35.35 : patch Linux kernel soon.
Data as of 26 Oct 2026, 17:16 UTC
- EPSS
- 0.6% chance of exploitation in 30 days – higher than 52% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 6.8.0-35.35, 6.8.0-1009.9, 6.8.0-1008.8 +7
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 1 May 2024
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade to a fixed release listed under Affected software.
Patches and advisories
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 24.04 LTSlinuxpkg:deb/ubuntu/linux?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Ubuntu 24.04 LTSlinux-awspkg:deb/ubuntu/linux-aws?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Ubuntu 24.04 LTSlinux-azurepkg:deb/ubuntu/linux-azure?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Ubuntu 24.04 LTSlinux-gcppkg:deb/ubuntu/linux-gcp?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Ubuntu 24.04 LTSlinux-gkepkg:deb/ubuntu/linux-gke?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Ubuntu 24.04 LTSlinux-ibmpkg:deb/ubuntu/linux-ibm?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
An official patch is available and should be applied to affected Linux kernel versions to remediate this vulnerability. Users should update to fixed kernel versions 6.8.0-35.35 or later, or the corresponding patched versions for other affected releases. No additional mitigation beyond applying the official fix is indicated.
Description
A slab-out-of-bounds vulnerability in the Linux kernel's ksmbd component was fixed. The issue occurs when the NameOffset field of smb2_create_req is smaller than the Buffer offset, leading to an out-of-bounds read. The patch enforces a minimum value for the name offset to prevent this. This vulnerability has a high severity score of 8.1 and affects multiple Linux kernel versions prior to 6.8.0-35.35 and certain specific older versions. A patch is available to address this issue.
References
- ubuntu.com/security/CVE-2024-26954 (opens in a new tab)
- cve.org/CVERecord?id=CVE-2024-26954 (opens in a new tab)
- git.kernel.org/linus/a80a486d72e20bd12c335bcd38b6e6f19356b0aa (opens in a new tab)
- git.kernel.org/stable/c/3b8da67191e938a63d2736dabb4ac5d337e5de57 (opens in a new tab)
- git.kernel.org/stable/c/4f97e6a9d62cb1fce82fbf4baff44b83221bc178 (opens in a new tab)
- git.kernel.org/stable/c/a80a486d72e20bd12c335bcd38b6e6f19356b0aa (opens in a new tab)
- ubuntu.com/security/notices/USN-6816-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-6817-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-6817-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-6817-3 (opens in a new tab)
- ubuntu.com/security/notices/USN-6878-1 (opens in a new tab)