Skip to main content
VulnerabilityPublished Updated

CVE-2024-27005: Linux kernel · interconnect: Don't access req_list while it's being manipulated

Affects Linux kernelSource GCVE Database

0

Not known to be exploited · CVSS 7.8 High · fixed in 6.8.0-1011.12~22.04.1 : patch Linux kernel soon.

Data as of 26 Oct 2026, 12:54 UTC

CVSS 3.1 base score
7.8High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 7% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 6.8.0-1011.12~22.04.1, 6.8.0-1010.10~22.04.1, 6.8.0-1009.9~22.04.1 +13
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 1 May 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
Ubuntu 24.04 LTSlinuxpkg:deb/ubuntu/linux?arch=source&distro=nobleOther threatsAffected
  • <6.8.0-38.38
Fixed in
  • 6.8.0-38.38
Ubuntu 24.04 LTSlinux-awspkg:deb/ubuntu/linux-aws?arch=source&distro=nobleOther threatsAffected
  • <6.8.0-1011.12
Fixed in
  • 6.8.0-1011.12
Ubuntu 24.04 LTSlinux-azurepkg:deb/ubuntu/linux-azure?arch=source&distro=nobleOther threatsAffected
  • <6.8.0-1010.10
Fixed in
  • 6.8.0-1010.10
Ubuntu 24.04 LTSlinux-gcppkg:deb/ubuntu/linux-gcp?arch=source&distro=nobleOther threatsAffected
  • <6.8.0-1010.11
Fixed in
  • 6.8.0-1010.11
Ubuntu 24.04 LTSlinux-gkepkg:deb/ubuntu/linux-gke?arch=source&distro=nobleOther threatsAffected
  • <6.8.0-1006.9
Fixed in
  • 6.8.0-1006.9
Ubuntu 24.04 LTSlinux-ibmpkg:deb/ubuntu/linux-ibm?arch=source&distro=nobleOther threatsAffected
  • <6.8.0-1008.8
Fixed in
  • 6.8.0-1008.8

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and should be applied promptly. The vendor advisory from Ubuntu confirms fixes in updated Linux kernel packages. After applying the update, a system reboot is required to complete remediation. No additional mitigation steps are necessary beyond applying the official kernel updates.

Description

A race condition vulnerability in the Linux kernel's interconnect subsystem was resolved by ensuring proper locking order when accessing the req_list. The issue involved concurrent access to icc_node::req_list protected by separate mutexes, causing potential invalid pointer dereferences. The fix enforces holding the icc_bw_lock mutex before manipulating req_list, preventing race conditions. This vulnerability affects multiple Linux kernel versions prior to 6.8.0-1011.12~22.04.1 and specific older versions. A patch is available, and users should update and reboot to apply the fix.

References

Community reviews

Loading reviews…