Skip to main content
VulnerabilityPublished

CVE-2024-27123: QNAP Systems QcalAgent · Cross-site Scripting

Affects QNAP Systems QcalAgentSource CVE Database V5

0
Compare

Public exploit available · CVSS 5.2 Medium : upgrade to 1.1.9 as a priority.

Data as of 2 Nov 2026, 10:57 UTC

CVSS 4.0 base score
5.2Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 8% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.1.9
CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:A/VC:H/VI:L/VA:N/SC:N/SI:N/SA:N/E:P

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 18 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: evidence found.

    CVSS exploit maturity: proof of concept public

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CVSS vector, the Metasploit, Exploit-DB and nuclei-templates index as of 2 Nov 2026.

What to do

Upgrade QNAP Systems QcalAgent to 1.1.9.

Affected software

ProductAffectedFixed in
QNAP Systems Inc.QcalAgentAffected
  • >=1.1.0 <1.1.9
Fixed in
  • 1.1.9

AI-suggested

Upgrade QcalAgent to version 1.1.9 or later to remediate this vulnerability. No other mitigation actions are specified or required.

Description

A cross-site scripting (XSS) vulnerability has been reported to affect QcalAgent. The local attackers can then exploit the vulnerability to bypass security mechanisms or read application data. We have already fixed the vulnerability in the following version: QcalAgent 1.1.9 and later

References

Community reviews

Loading reviews…