CVE-2024-28662: Piwigo · Cross-site Scripting
Affects PiwigoSource CVE Database V5
Not known to be exploited · CVSS 5.4 Medium : upgrade to 14.3.0 when convenient.
Data as of 26 Oct 2026, 10:12 UTC
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 37% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 14.3.0
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:NExploitation evidence
Disclosed: evidence found.
CVE published 13 Mar 2024
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade piwigo/Piwigo to 14.3.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
GitHubpiwigo/Piwigopkg:github/piwigo/PiwigoOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
To mitigate CVE-2024-28662, organizations should immediately upgrade Piwigo installations to version 14.3.0 or later, where the vulnerability is patched. If upgrading is not immediately possible, administrators should restrict access to the administrative interface by IP whitelisting or VPN enforcement to reduce exposure. Implement strict authentication policies including strong passwords and multi-factor authentication to limit the risk of compromised credentials. Monitor web server logs and application behavior for unusual input patterns or script injection attempts. Employ web application firewalls (WAFs) with rules targeting XSS payloads to provide an additional layer of defense. Educate administrators and users about phishing and social engineering risks that could facilitate exploitation. Regularly review and sanitize all user inputs in custom plugins or extensions to prevent similar vulnerabilities. Finally, maintain an incident response plan to quickly address any detected exploitation attempts.
Description
A Cross Site Scripting vulnerability exists in Piwigo before 14.3.0 script because of missing sanitization in create_tag in admin/include/functions.php.