CVE-2024-30204: emacs · Incorrect Default Permissions
Affects emacsSource CVE Database V5
Not known to be exploited · CVSS 2.8 Low : upgrade to 29.3 when convenient.
Data as of 26 Oct 2026, 17:16 UTC
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 40% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 29.3
CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:U/C:N/I:N/A:LExploitation evidence
Disclosed: evidence found.
CVE published 25 Mar 2024
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade the Debian debian/emacs package to 29.3.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Debiandebian/emacspkg:deb/debian/emacsOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
To mitigate CVE-2024-30204, organizations and users should first consider upgrading Emacs to version 29.3 or later, where this vulnerability is addressed. If immediate upgrade is not feasible, users should disable the default LaTeX preview feature for email attachments by adjusting Emacs configuration settings to prevent automatic rendering. Specifically, modifying or disabling the relevant hooks or functions that trigger LaTeX preview on email attachments can reduce exposure. Additionally, users should exercise caution when opening emails with LaTeX attachments from untrusted sources, and implement email filtering to block or quarantine suspicious attachments. Employing endpoint security solutions that monitor resource usage anomalies may help detect exploitation attempts. Regularly reviewing and applying security updates for Emacs and related packages is essential. Finally, educating users about the risks of opening unexpected LaTeX attachments can further reduce the likelihood of exploitation.
Description
In Emacs before 29.3, LaTeX preview is enabled by default for e-mail attachments.
References
- git.savannah.gnu.org/cgit/emacs.git/tree/etc/NEWS?h=emacs-29 (opens in a new tab)
- git.savannah.gnu.org/cgit/emacs.git/commit/?h=emacs-29&id=6f9ea396f49cbe38c2173e0a72ba6af3e03b271c (opens in a new tab)
- lists.debian.org/debian-lts-announce/2024/04/msg00023.html (opens in a new tab)
- lists.debian.org/debian-lts-announce/2024/04/msg00024.html (opens in a new tab)
- openwall.com/lists/oss-security/2024/03/25/2 (opens in a new tab)
- openwall.com/lists/oss-security/2024/04/08/4 (opens in a new tab)
- openwall.com/lists/oss-security/2024/04/10/3 (opens in a new tab)
- openwall.com/lists/oss-security/2024/04/11/4 (opens in a new tab)
- openwall.com/lists/oss-security/2024/04/10/4 (opens in a new tab)
- openwall.com/lists/oss-security/2024/04/08/6 (opens in a new tab)
- openwall.com/lists/oss-security/2024/04/10/5 (opens in a new tab)
- openwall.com/lists/oss-security/2024/04/08/7 (opens in a new tab)
- openwall.com/lists/oss-security/2024/04/08/3 (opens in a new tab)
- openwall.com/lists/oss-security/2024/04/10/6 (opens in a new tab)