CVE-2024-31365: Post Type Builder (PTB) (WordPress plugin) · Cross-site Scripting
Affects Post Type Builder (PTB) (WordPress plugin)Source CVE Database V5
Not known to be exploited · CVSS 7.1 High : upgrade to 2.1.1 soon.
Data as of 26 Oct 2026, 06:26 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 28% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.1.1
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:LExploitation evidence
Disclosed: evidence found.
CVE published 9 Apr 2024
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.
What to do
Upgrade Post Type Builder (PTB) (WordPress plugin) to 2.1.1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Themify Post Type Builder (PTB) | Affected
| Fixed in
|
AI-suggested
If you cannot patch yet, users should consider applying temporary mitigations such as disabling or restricting the use of the Post Type Builder plugin, or employing web application firewalls (WAF) that can detect and block reflected XSS attempts.
Description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Themify Post Type Builder (PTB) allows Reflected XSS.This issue affects Post Type Builder (PTB): from n/a before 2.1.1.