CVE-2024-31920: Currency per Product for WooCommerce (WordPress plugin) · Cross-Site Request Forgery (CSRF)
Affects Currency per Product for WooCommerce (WordPress plugin)Source CVE Database V5
Not known to be exploited · CVSS 4.3 Medium : upgrade to 1.6.1 when convenient.
Data as of 26 Oct 2026, 08:30 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 9% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.6.1
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:NExploitation evidence
Disclosed: evidence found.
CVE published 15 Apr 2024
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade Currency per Product for WooCommerce (WordPress plugin) to 1.6.1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Tyche Softwares Currency per Product for WooCommerce | Affected
| Fixed in
|
AI-suggested
If you cannot patch yet, users should consider implementing CSRF protections such as verifying nonces or tokens in requests if possible. Monitoring for updates from Tyche Softwares is recommended to apply an official fix once available.
Description
Cross-Site Request Forgery (CSRF) vulnerability in Tyche Softwares Currency per Product for WooCommerce.This issue affects Currency per Product for WooCommerce: from n/a through 1.6.0.