Skip to main content
CVE-2024-3238VulnerabilityPublished Updated

CVE-2024-3238: looks_awesome WordPress Menu Plugin – Superfly Responsive Menu · Cross-Site Request Forgery (CSRF)

Affects looks_awesome WordPress Menu Plugin – Superfly Responsive MenuSource CVE Database V5

0

Not known to be exploited · CVSS 8.8 High · fixed in 5.0.28 : patch looks_awesome WordPress Menu Plugin – Superfly Responsive Menu soon.

Data as of 26 Oct 2026, 06:26 UTC

CVSS 3.1 base score
8.8High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 34% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 5.0.28
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 2 Aug 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.

What to do

Affected software

ProductAffectedFixed in
looks_awesome WordPress Menu Plugin — Superfly Responsive MenuAffected
  • =0
Fixed in–

AI-suggested

Upgrade the Superfly Responsive Menu plugin to version 5.0.30 or later to ensure both CSRF and directory traversal protections are in place. Versions 5.0.28 and 5.0.29 only partially address the issue and are not sufficient. No other mitigations are indicated by the vendor advisory.

Description

The WordPress Menu Plugin — Superfly Responsive Menu plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 5.0.29. This is due to missing or incorrect nonce validation on the ajax_handle_delete_icons() function. This makes it possible for unauthenticated attackers to delete arbitrary files via a forged request granted they can trick a site administrator into performing an action such as clicking on a link. Please not the CSRF was patched in 5.0.28, however, adequate directory traversal protection wasn't introduced until 5.0.30.

References

Community reviews

Loading reviews…