Skip to main content
VulnerabilityPublished Updated

CVE-2024-32465: git · Path Traversal

Affects gitSource GCVE Database

0
Compare

Mentioned vulnerabilities

Not known to be exploited · CVSS 7.4 High · fixed in 2.43.4 : patch git soon.

Data as of 31 Oct 2026, 01:22 UTC

CVSS 3.1 base score
7.4High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (GitHub_M)CVSS 3.17.4
Patch
Available – fixed in 2.43.4, 2.42.2, 2.40.2 +1
CVSS:3.1/AV:P/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 14 May 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade git to 2.43.4, 2.42.2, 2.40.2 or 2.39.4.

Affected software

ProductAffectedFixed in
git gitAffected
  • =2.45.0
  • =2.44.0
  • >=2.43.0 <2.43.4
  • >=2.42.0 <2.42.2
  • =2.41.0
  • >=2.40.0 <2.40.2
  • <2.39.4
Fixed in
  • 2.43.4
  • 2.42.2
  • 2.40.2
  • 2.39.4

AI-suggested

Upgrade Git to one of the fixed versions: 2.39.4, 2.40.2, 2.41.1, 2.42.2, 2.43.4, or 2.44.1. As a workaround, avoid using Git on repositories obtained from untrusted archive sources such as .zip files. The Git project recommends cloning repositories with 'git clone --no-local' to obtain a clean copy from untrusted sources. Follow official Git advisories for the latest remediation guidance.

Description

CVE-2024-32465 is a path traversal vulnerability in Git that affects certain versions prior to patched releases. It allows bypassing protections when working with untrusted repositories, especially when repositories are obtained as archives like .zip files. This can lead to execution of malicious hooks within the repository context. The issue has been fixed in multiple Git versions starting from 2.39.4, 2.40.2, 2.41.1, 2.42.2, 2.43.4, and 2.44.1. Users are advised to avoid using Git on repositories obtained from untrusted archive sources or to upgrade to patched versions.

References

Community reviews

Loading reviews…