Skip to main content
VulnerabilityPublished Updated

CVE-2024-3249: Zita Site Library for Elementor (WordPress plugin) · Missing Authorization

Affects Zita Site Library for Elementor (WordPress plugin)Source CVE Database V5

0

Not known to be exploited · CVSS 4.3 Medium · fixed in 1.6.2 : update Zita Site Library for Elementor (WordPress plugin) when convenient.

Data as of 26 Oct 2026, 10:12 UTC

CVSS 3.1 base score
4.3Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 27% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.6.2
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 25 Jun 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
wpzita Zita Site Library for ElementorAffected
  • =0
Fixed in–

AI-suggested

The vulnerability was partially fixed in version 1.6.2, so upgrading to the latest plugin version is recommended if a newer version beyond 1.6.2 is available. Until a full fix is confirmed, restrict subscriber-level access and review user permissions carefully to limit exposure. Monitor vendor channels for an official fix or updated security guidance.

Description

The Zita Elementor Site Library plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the import_xml_data, xml_data_import, import_option_data, import_widgets, and import_customizer_settings functions in all versions up to, and including, 1.6.2. This makes it possible for authenticated attackers, with subscriber-level access and above, to create pages, update certain options, including WooCommerce page titles and Elementor settings, import widgets, and update the plugin's customizer settings and the WordPress custom CSS. NOTE: This vulnerability was partially fixed in version 1.6.2.

References

Community reviews

Loading reviews…