CVE-2024-32595: Mat Bao WP Helper Premium · Cross-site Scripting
Affects Mat Bao WP Helper PremiumSource CVE Database V5
Not known to be exploited · CVSS 7.1 High : upgrade to 4.6.0 soon.
Data as of 26 Oct 2026, 14:05 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 33% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 4.6.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:LExploitation evidence
Disclosed: evidence found.
CVE published 18 Apr 2024
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade Mat Bao WP Helper Premium to 4.6.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Mat Bao Corp WP Helper Premium | Affected
| Fixed in
|
AI-suggested
If you cannot patch yet, users should consider applying standard XSS mitigations such as input validation and output encoding where possible.
Description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Mat Bao Corp WP Helper Premium allows Reflected XSS.This issue affects WP Helper Premium: from n/a before 4.6.0.