Skip to main content
CVE-2024-34091VulnerabilityPublished Updated

CVE-2024-34091: n/a

Source CVE Database V5

0

Not known to be exploited · CVSS 7.3 High · fixed in 2024.04 : patch affected systems soon.

Data as of 26 Oct 2026, 06:26 UTC

CVSS 3.1 base score
7.3High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.5% chance of exploitation in 30 days – higher than 42% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2024.04, 6.14.0.3
CVSS:3.1/AC:L/AV:N/A:N/C:H/I:H/PR:L/S:U/UI:R

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 6 May 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.

What to do

AI-suggested

To mitigate CVE-2024-34091, organizations should immediately upgrade affected Archer Platform instances to version 2024.04 or later, or apply the 6.14.0.3 fixed release if using the 6.14 branch. In addition to patching, implement strict input validation and output encoding on all user-supplied data fields to prevent injection of malicious scripts. Limit authenticated user privileges to the minimum necessary to reduce the risk of exploitation by low-privilege users. Employ Content Security Policy (CSP) headers to restrict the execution of unauthorized scripts within the application context. Monitor application logs for unusual input patterns or repeated failed attempts to inject scripts. Conduct regular security awareness training for users to recognize and report suspicious behavior. Finally, consider deploying web application firewalls (WAFs) with rules tuned to detect and block XSS payloads targeting the Archer Platform.

Description

An issue was discovered in Archer Platform 6 before 2024.04. There is a stored cross-site scripting (XSS) vulnerability. A remote authenticated malicious Archer user could potentially exploit this vulnerability to store malicious HTML or JavaScript code in a trusted application data store. When victim users access the data store through their browsers, the malicious code gets executed in the background of the application and renders content inaccessible.6.14 P3 (6.14.0.3) is also a fixed release.

References

Community reviews

Loading reviews…