Skip to main content
VulnerabilityPublished Updated

CVE-2024-38396: iterm2 · Code Injection

Affects iterm2Source CVE Database V5

0

Mentioned vulnerabilities

Not known to be exploited · CVSS 9.8 Critical : upgrade to 3.5.2 as a priority.

Data as of 26 Oct 2026, 13:47 UTC

CVSS 3.1 base score
9.8Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
1.6% chance of exploitation in 30 days – higher than 76% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 3.5.2
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 16 Jun 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade gnachman/iterm2 to 3.5.2.

Affected software

ProductAffectedFixed in
GitHubgnachman/iterm2pkg:github/gnachman/iterm2Other threatsAffected
  • <3.5.2
Fixed in
  • 3.5.2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

To mitigate CVE-2024-38396, organizations should immediately upgrade iTerm2 to version 3.5.2 or later, where the vulnerability has been patched. If upgrading is not immediately feasible, temporarily disabling the tmux integration feature can reduce exposure, as this feature is integral to the exploit path. Additionally, users should restrict terminal access to trusted networks and employ network segmentation to limit potential attack vectors. Monitoring terminal logs for unusual escape sequences or unexpected terminal behavior can help detect exploitation attempts. Implementing endpoint detection and response (EDR) solutions with capabilities to identify anomalous code execution in terminal processes is advisable. Security teams should also educate users about the risks of using untrusted terminal sessions and avoid opening terminal windows or sessions from unknown sources. Regularly reviewing and updating terminal emulator configurations to minimize unnecessary features can further reduce attack surfaces.

Description

An issue was discovered in iTerm2 3.5.x before 3.5.2. Unfiltered use of an escape sequence to report a window title, in combination with the built-in tmux integration feature (enabled by default), allows an attacker to inject arbitrary code into the terminal, a different vulnerability than CVE-2024-38395.

References

Community reviews

Loading reviews…