Skip to main content
VulnerabilityPublished Updated

CVE-2024-38439: netatalk · Out-of-bounds Write

Affects netatalkSource CVE Database V5

0

Not known to be exploited · CVSS 9.8 Critical · fixed in 3.2.1 : patch netatalk as a priority.

Data as of 26 Oct 2026, 17:16 UTC

CVSS 3.1 base score
9.8Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.9% chance of exploitation in 30 days – higher than 60% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 3.2.1, 3.1.19, 2.4.1
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 16 Jun 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade netatalk/netatalk to 3.2.1, 3.1.19 or 2.4.1.

Affected software

ProductAffectedFixed in
GitHubnetatalk/netatalkpkg:github/netatalk/netatalkOther threatsAffected
  • <2.4.1
  • <3.1.19
  • <3.2.1
Fixed in
  • 2.4.1
  • 3.1.19
  • 3.2.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

To mitigate CVE-2024-38439, organizations should immediately upgrade Netatalk to version 3.2.1 or later, or apply backported patches available in versions 2.4.1 and 3.1.19. Network administrators should audit and restrict access to AFP services, ideally limiting exposure to trusted internal networks or VPNs. Implementing network-level protections such as firewalls and intrusion detection/prevention systems (IDS/IPS) can help detect and block exploitation attempts. Regularly review PAM configurations to ensure no additional vulnerabilities exist. Organizations should also conduct vulnerability scans to identify any remaining vulnerable Netatalk instances. Monitoring logs for unusual login attempts or crashes related to the PAM module can provide early indicators of exploitation attempts. Finally, maintaining an up-to-date asset inventory and patch management process is critical to prevent exploitation of this and similar vulnerabilities.

Description

Netatalk before 3.2.1 has an off-by-one error and resultant heap-based buffer overflow because of setting ibuf[PASSWDLEN] to '\0' in FPLoginExt in login in etc/uams/uams_pam.c.2.4.1 and 3.1.19 are also fixed versions.

References

Community reviews

Loading reviews…