CVE-2024-38472: Apache HTTP Server · Server-Side Request Forgery
Affects Apache HTTP ServerSource CVE Database V5
Not known to be exploited · public detection template (Nuclei) · 69% EPSS · CVSS 7.5 High · fixed in 2.4.60 : patch Apache HTTP Server as a priority.
Data as of 3 Nov 2026, 22:57 UTC
Thin evidence
One scorer or none| CISA-ADP | CVSS 3.1 | 7.5 |
|---|
- EPSS
- 69.4% chance of exploitation in 30 days – higher than 99% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- CISA SSVC
- Exploitation
- No evidence of active exploitation and no public proof of concept
- Automatable
- Attackers can reliably automate steps 1–4 of the kill chain
- Technical impact
- Total control over the software or total information disclosure
CISA SSVC assessment, 2024-07-26.
- Patch
- Available – fixed in 2.4.60
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:NExploitation evidence
Disclosed: evidence found.
CVE published 1 Jul 2024
Detectable: evidence found.
nuclei template: Apache HTTPd Windows UNC - Server-Side Request Forgery
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Apache Software FoundationApache HTTP Server | Affected
| Fixed in– |
AI-suggested
Users should upgrade Apache HTTP Server to version 2.4.60 or later, where this vulnerability is fixed. For existing configurations that access UNC paths, administrators must configure the new "UNCList" directive to permit access during request processing. No other mitigation steps are indicated by the vendor advisory.
Description
CVE-2024-38472 is a Server-Side Request Forgery (SSRF) vulnerability in Apache HTTP Server on Windows platforms. This flaw allows an attacker to potentially leak NTLM hashes to a malicious server by exploiting SSRF and crafted requests or content. The issue affects Apache HTTP Server versions from 2.4.0 up to and including 2.4.59. The Apache Software Foundation has released version 2.4.60 to address this vulnerability. Users with configurations accessing UNC paths must also configure the new "UNCList" directive to maintain access during request processing.