CVE-2024-38599: Linux kernel · jffs2: prevent xattr node from overflowing the eraseblock
Affects Linux kernelSource GCVE Database
Not known to be exploited · CVSS 7.8 High · fixed in 5.4.0-1130.140~18.04.1 : patch Linux kernel soon.
Data as of 28 Oct 2026, 11:14 UTC
- Patch
- Available – fixed in 5.4.0-1130.140~18.04.1, 5.4.0-1135.142~18.04.1, 5.4.0-1134.143~18.04.1 +73
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 19 Jun 2024
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade to a fixed release listed under Affected software.
Patches and advisories
- ubuntu.com/security/notices/USN-6949-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-6951-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-6952-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-6953-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-6955-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-6949-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-6952-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-6951-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-6951-3 (opens in a new tab)
- ubuntu.com/security/notices/USN-6951-4 (opens in a new tab)
- ubuntu.com/security/notices/USN-6979-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7007-1 (opens in a new tab)
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 24.04 LTSlinuxpkg:deb/ubuntu/linux?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Ubuntu 24.04 LTSlinux-awspkg:deb/ubuntu/linux-aws?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Ubuntu 24.04 LTSlinux-azurepkg:deb/ubuntu/linux-azure?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Ubuntu 24.04 LTSlinux-gcppkg:deb/ubuntu/linux-gcp?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Ubuntu 24.04 LTSlinux-gkepkg:deb/ubuntu/linux-gke?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Ubuntu 24.04 LTSlinux-ibmpkg:deb/ubuntu/linux-ibm?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available and has been applied in multiple Linux kernel releases including versions 5.4.0-1130.140~18.04.1 and later. Users and administrators should update affected Linux kernel versions to these fixed releases or later to remediate the vulnerability. No additional mitigation steps are required beyond applying the official kernel updates.
Description
CVE-2024-38599 is a vulnerability in the Linux kernel's JFFS2 filesystem where an xattr node can overflow the eraseblock, causing filesystem corruption and potential kernel crashes. The flaw arises because xattr nodes are not split across eraseblocks, so a large xattr node can spill over into the next eraseblock, leading to errors and KASAN slab-out-of-bounds crashes. This issue has been fixed by adding a check to ensure the xattr node size does not exceed the eraseblock size minus the cleanmarker. Multiple affected Linux kernel versions have patches available.
References
- ubuntu.com/security/CVE-2024-38599 (opens in a new tab)
- cve.org/CVERecord?id=CVE-2024-38599 (opens in a new tab)
- git.kernel.org/linus/c6854e5a267c28300ff045480b5a7ee7f6f1d913 (opens in a new tab)
- git.kernel.org/stable/c/2904e1d9b64f72d291095e3cbb31634f08788b11 (opens in a new tab)
- git.kernel.org/stable/c/526235dffcac74c7823ed504dfac4f88d84ba5df (opens in a new tab)
- git.kernel.org/stable/c/f0eea095ce8c959b86e1e57fe36ca4fea5ae54f8 (opens in a new tab)
- git.kernel.org/stable/c/a1d21bcd78cf4a4353e1e835789429c6b76aca8b (opens in a new tab)
- git.kernel.org/stable/c/f06969df2e40ab1dc8f4364a5de967830c74a098 (opens in a new tab)
- git.kernel.org/stable/c/af82d8d2179b7277ad627c39e7e0778f1c86ccdb (opens in a new tab)
- git.kernel.org/stable/c/8d431391320c5c5398ff966fb3a95e68a7def275 (opens in a new tab)
- git.kernel.org/stable/c/978a12c91b38bf1a213e567f3c20e2beef215f07 (opens in a new tab)
- git.kernel.org/stable/c/c6854e5a267c28300ff045480b5a7ee7f6f1d913 (opens in a new tab)
- ubuntu.com/security/notices/USN-6949-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-6951-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-6952-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-6953-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-6955-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-6949-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-6952-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-6951-2 (opens in a new tab)