CVE-2024-39499: Linux kernel · vmci: prevent speculation leaks by sanitizing event in event_deliver()
Affects Linux kernelSource GCVE Database
Not known to be exploited · CVSS 7.1 High · fixed in 5.4.0-1132.142~18.04.1 : patch Linux kernel soon.
Data as of 28 Oct 2026, 11:02 UTC
- Patch
- Available – fixed in 5.4.0-1132.142~18.04.1, 5.4.0-1137.144~18.04.1, 5.4.0-1136.145~18.04.1 +71
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 12 Jul 2024
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade to a fixed release listed under Affected software.
Patches and advisories
- ubuntu.com/security/notices/USN-6999-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7003-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7003-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-7004-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7005-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7006-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7003-3 (opens in a new tab)
- ubuntu.com/security/notices/USN-7007-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7008-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7005-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-7009-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7019-1 (opens in a new tab)
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 24.04 LTSlinuxpkg:deb/ubuntu/linux?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Ubuntu 24.04 LTSlinux-awspkg:deb/ubuntu/linux-aws?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Ubuntu 24.04 LTSlinux-azurepkg:deb/ubuntu/linux-azure?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Ubuntu 24.04 LTSlinux-gcppkg:deb/ubuntu/linux-gcp?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Ubuntu 24.04 LTSlinux-gkepkg:deb/ubuntu/linux-gke?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Ubuntu 24.04 LTSlinux-ibmpkg:deb/ubuntu/linux-ibm?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available and has been released in multiple Linux kernel versions including 5.4.0-1132.142~18.04.1 and later. Users and administrators should update their Linux kernel to one of the fixed versions to mitigate this vulnerability. No additional mitigation steps are required beyond applying the official kernel updates.
Description
CVE-2024-39499 is a high-severity vulnerability in the Linux kernel's VMware VMCI driver where user-controlled event data was not properly sanitized before use, leading to potential speculative execution information leaks. The flaw was identified by static analysis and fixed by sanitizing the event index in the event_deliver() function. Multiple Linux kernel versions prior to fixed releases are affected. No known exploits in the wild have been reported. A patch is available and included in various updated Linux kernel releases.
References
- ubuntu.com/security/CVE-2024-39499 (opens in a new tab)
- cve.org/CVERecord?id=CVE-2024-39499 (opens in a new tab)
- git.kernel.org/linus/8003f00d895310d409b2bf9ef907c56b42a4e0f4 (opens in a new tab)
- ubuntu.com/security/notices/USN-6999-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7003-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7003-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-7004-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7005-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7006-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7003-3 (opens in a new tab)
- ubuntu.com/security/notices/USN-7007-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7008-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7005-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-7009-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7019-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7007-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-6999-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-7007-3 (opens in a new tab)
- ubuntu.com/security/notices/USN-7029-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7009-2 (opens in a new tab)