CVE-2024-39508: Linux kernel · io_uring/io-wq: Use set_bit() and test_bit() at worker->flags
Affects Linux kernelSource GCVE Database
Not known to be exploited · CVSS 7.8 High · fixed in 6.8.0-1015.16~22.04.1 : patch Linux kernel soon.
Data as of 28 Oct 2026, 11:02 UTC
- Patch
- Available – fixed in 6.8.0-1015.16~22.04.1, 6.8.0-1014.16~22.04.1, 6.8.0-45.45~22.04.1 +16
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 12 Jul 2024
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade to a fixed release listed under Affected software.
Patches and advisories
- ubuntu.com/security/notices/USN-6999-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7004-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7005-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7008-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7005-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-6999-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-7029-1 (opens in a new tab)
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 24.04 LTSlinuxpkg:deb/ubuntu/linux?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Ubuntu 24.04 LTSlinux-awspkg:deb/ubuntu/linux-aws?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Ubuntu 24.04 LTSlinux-azurepkg:deb/ubuntu/linux-azure?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Ubuntu 24.04 LTSlinux-gcppkg:deb/ubuntu/linux-gcp?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Ubuntu 24.04 LTSlinux-gkepkg:deb/ubuntu/linux-gke?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Ubuntu 24.04 LTSlinux-ibmpkg:deb/ubuntu/linux-ibm?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch addressing this vulnerability is available and included in Linux kernel versions 6.8.0-1015.16~22.04.1 and later. Users and administrators should update affected Linux kernel packages to these fixed versions or newer as provided by their distribution vendors. No additional mitigation is required beyond applying the official kernel updates.
Description
CVE-2024-39508 is a concurrency vulnerability in the Linux kernel's io_uring/io-wq subsystem. It involves data races on the io_worker->flags structure due to non-atomic manipulation of flags across multiple CPU cores. The flaw was identified by Kernel Concurrency Sanitizer (KCSAN) detecting conflicting reads and writes in io_worker_handle_work and io_wq_activate_free_worker functions. The issue is resolved by refactoring the code to use atomic bit operations (set_bit(), test_bit()) to ensure thread-safe access. Multiple Linux kernel versions prior to 6.8.0-1015.16~22.04.1 and several specific older versions are affected. A fix is available in kernel versions 6.8.0-1015.16~22.04.1 and later.
References
- ubuntu.com/security/CVE-2024-39508 (opens in a new tab)
- cve.org/CVERecord?id=CVE-2024-39508 (opens in a new tab)
- git.kernel.org/linus/8a565304927fbd28c9f028c492b5c1714002cbab (opens in a new tab)
- git.kernel.org/stable/c/ab702c3483db9046bab9f40306f1a28b22dbbdc0 (opens in a new tab)
- git.kernel.org/stable/c/1cbb0affb15470a9621267fe0a8568007553a4bf (opens in a new tab)
- git.kernel.org/stable/c/8a565304927fbd28c9f028c492b5c1714002cbab (opens in a new tab)
- ubuntu.com/security/notices/USN-6999-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7004-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7005-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7008-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7005-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-6999-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-7029-1 (opens in a new tab)