CVE-2024-39652: WooCommerce PDF Vouchers (WordPress plugin) · XSS or 'Cross-site Scripting'
Affects WooCommerce PDF Vouchers (WordPress plugin)Source CVE Database V5
Not known to be exploited · CVSS 7.1 High : upgrade to 4.9.5 soon.
Data as of 26 Oct 2026, 06:26 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 23% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 4.9.5
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:LExploitation evidence
Disclosed: evidence found.
CVE published 1 Aug 2024
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.
What to do
Upgrade WooCommerce PDF Vouchers (WordPress plugin) to 4.9.5.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| WPWeb Elite WooCommerce PDF Vouchers | Affected
| Fixed in
|
AI-suggested
If you cannot patch yet, users should consider disabling or limiting use of the affected plugin version and apply web application firewall (WAF) rules to detect and block reflected XSS attempts specific to this plugin. Avoid clicking on suspicious links that may exploit this vulnerability.
Description
Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in WPWeb Elite WooCommerce PDF Vouchers allows Reflected XSS.This issue affects WooCommerce PDF Vouchers: from n/a before 4.9.5.