CVE-2024-40966: Linux kernel · tty: add the option to have a tty reject a new ldisc
Affects Linux kernelSource GCVE Database
Not known to be exploited · CVSS 5.5 Medium · fixed in 6.8.0-1015.16~22.04.1 : update Linux kernel when convenient.
Data as of 28 Oct 2026, 11:01 UTC
- Patch
- Available – fixed in 6.8.0-1015.16~22.04.1, 6.8.0-1014.16~22.04.1, 6.8.0-45.45~22.04.1 +16
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 12 Jul 2024
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade to a fixed release listed under Affected software.
Patches and advisories
- ubuntu.com/security/notices/USN-6999-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7004-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7005-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7008-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7005-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-6999-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-7029-1 (opens in a new tab)
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 24.04 LTSlinuxpkg:deb/ubuntu/linux?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Ubuntu 24.04 LTSlinux-awspkg:deb/ubuntu/linux-aws?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Ubuntu 24.04 LTSlinux-azurepkg:deb/ubuntu/linux-azure?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Ubuntu 24.04 LTSlinux-gcppkg:deb/ubuntu/linux-gcp?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Ubuntu 24.04 LTSlinux-gkepkg:deb/ubuntu/linux-gke?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Ubuntu 24.04 LTSlinux-ibmpkg:deb/ubuntu/linux-ibm?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available and has been released in Linux kernel versions 6.8.0-1015.16~22.04.1 and later. Users and administrators should update affected Linux kernel versions to these fixed releases to remediate the vulnerability. No additional mitigation actions are indicated by the vendor advisory.
Description
CVE-2024-40966 is a vulnerability in the Linux kernel's tty subsystem that addresses an issue where virtual terminals could attach new line disciplines (ldiscs) that violate kernel context rules, causing kernel bugs. Specifically, the con_write() routine violates the "writes cannot sleep" rule, leading to a BUG error when certain ldiscs like N_GSM are attached and con_write() is called while holding a spinlock. This flaw could cause system instability or crashes. The vulnerability has been fixed in Linux kernel versions 6.8.0-1015.16~22.04.1 and later.
References
- ubuntu.com/security/CVE-2024-40966 (opens in a new tab)
- cve.org/CVERecord?id=CVE-2024-40966 (opens in a new tab)
- git.kernel.org/linus/6bd23e0c2bb6c65d4f5754d1456bc9a4427fc59b (opens in a new tab)
- git.kernel.org/stable/c/3c6332f3bb1578b5b10ac2561247b1d6272ae937 (opens in a new tab)
- git.kernel.org/stable/c/287b569a5b914903ba7c438a3c0dbc3410ebb409 (opens in a new tab)
- git.kernel.org/stable/c/5920ac19964f9e20181f63b410d9200ddbf8dc86 (opens in a new tab)
- git.kernel.org/stable/c/6bd23e0c2bb6c65d4f5754d1456bc9a4427fc59b (opens in a new tab)
- ubuntu.com/security/notices/USN-6999-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7004-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7005-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7008-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7005-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-6999-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-7029-1 (opens in a new tab)