Skip to main content
VulnerabilityPublished Updated

CVE-2024-41640: CVE-2024-41640 · Cross Site Scripting (XSS)

Affects CVE-2024-41640Source CVE Database V5

0

Not known to be exploited · CVSS 6.1 Medium : upgrade to 3.6 when convenient.

Data as of 26 Oct 2026, 17:16 UTC

CVSS 3.1 base score
6.1Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.6% chance of exploitation in 30 days – higher than 49% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 3.6
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 29 Jul 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade alemusix/CVE-2024-41640 to 3.6.

Affected software

ProductAffectedFixed in
GitHubalemusix/CVE-2024-41640pkg:github/alemusix/CVE-2024-41640Other threatsAffected
  • <3.6
Fixed in
  • 3.6

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Organizations should immediately review their AML Surety Eco deployments and restrict exposure of the vulnerable application to untrusted networks. Implementing web application firewalls (WAFs) with rules to detect and block suspicious input patterns in the 'id' parameter can provide temporary protection. Educate users to avoid clicking on suspicious links and implement Content Security Policy (CSP) headers to reduce the impact of injected scripts. Developers should prioritize releasing patches that properly sanitize and encode user input for the 'id' parameter. If you cannot patch yet, consider disabling or restricting the functionality that processes the 'id' parameter if feasible. Regularly monitor logs for unusual GET requests containing suspicious payloads. Conduct security awareness training to reduce the likelihood of successful social engineering attacks exploiting this vulnerability.

Description

Cross Site Scripting (XSS) vulnerability in AML Surety Eco up to 3.5 allows an attacker to run arbitrary code via crafted GET request using the id parameter.

References

Community reviews

Loading reviews…