CVE-2024-42360: wurmlab sequenceserver · Command Injection
Affects wurmlab sequenceserverSource CVE Database V5
Not known to be exploited · CVSS 9.8 Critical : upgrade to 3.1.2 as a priority.
Data as of 29 Oct 2026, 19:15 UTC
Contested
Critical score, yet low EPSS after six months · One scorer or none| CNA (GitHub_M) | CVSS 3.1 | 9.8 |
|---|
- EPSS
- 0.5% chance of exploitation in 30 days – higher than 47% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- CISA SSVC
- Exploitation
- No evidence of active exploitation and no public proof of concept
- Automatable
- Attackers can reliably automate steps 1–4 of the kill chain
- Technical impact
- Total control over the software or total information disclosure
CISA SSVC assessment, 2026-10-29.
- Patch
- Available – fixed in 3.1.2
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 14 Aug 2024
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade sequenceserver and wurmlab/sequenceserver to 3.1.2.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| wurmlabsequenceserver | Affected
| Fixed in
|
GitHubwurmlab/sequenceserverpkg:github/wurmlab/sequenceserverOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade SequenceServer to version 3.1.2 or later, where this vulnerability has been fixed. No other mitigation is required as the fix addresses the root cause.
Description
SequenceServer versions prior to 3.1.2 contain a critical command injection vulnerability (CWE-77) due to improper sanitization of user input in several HTTP endpoints. This flaw allows unauthenticated attackers to inject and execute arbitrary shell commands. The vulnerability has been fixed in version 3.1.2.