CVE-2024-43943: Greenshift Woocommerce Addon (WordPress plugin) · SQL Injection
Affects Greenshift Woocommerce Addon (WordPress plugin)Source CVE Database V5
Not known to be exploited · CVSS 8.5 High : upgrade to 1.9.8 soon.
Data as of 25 Oct 2026, 19:02 UTC
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 38% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.9.8
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:N/A:LExploitation evidence
Disclosed: evidence found.
CVE published 29 Aug 2024
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.
What to do
Upgrade Greenshift Woocommerce Addon (WordPress plugin) to 1.9.8.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Wpsoul Greenshift Woocommerce Addon | Affected
| Fixed in
|
AI-suggested
If you cannot patch yet, users should consider restricting access to the affected addon and monitor for unusual database activity. Avoid exposing the vulnerable component to untrusted networks if possible.
Description
Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in Wpsoul Greenshift Woocommerce Addon allows SQL Injection.This issue affects Greenshift Woocommerce Addon: from n/a before 1.9.8.