CVE-2024-45237: Fort · Classic Buffer Overflow
Source CVE Database V5
Not known to be exploited · CVSS 9.8 Critical · fixed in 1.6.3 : patch Fort as a priority.
Data as of 26 Oct 2026, 16:39 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 29% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Affects
- Fort before 1.6.3
- Patch
- Available – fixed in 1.6.3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 24 Aug 2024
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
AI-suggested
To mitigate CVE-2024-45237, European organizations using Fort should immediately upgrade to version 1.6.3 or later where the vulnerability is patched. If immediate patching is not possible, organizations should implement network-level controls to restrict access to RPKI repositories, especially those not fully trusted or verified. Deploying strict validation and filtering of RPKI data sources can reduce exposure to malicious repositories. Monitoring network traffic for unusual rsync or RRDP activity and implementing anomaly detection on RPKI update patterns can help detect exploitation attempts. Organizations should also review and harden the security posture of servers running Fort, including applying least privilege principles, isolating RPKI validation services, and enabling logging and alerting for suspicious behavior. Collaboration with RPKI Trust Anchor operators to ensure repository integrity and timely revocation of compromised repositories is recommended. Finally, organizations should stay informed on vendor advisories and threat intelligence updates related to this vulnerability.
Description
An issue was discovered in Fort before 1.6.3. A malicious RPKI repository that descends from a (trusted) Trust Anchor can serve (via rsync or RRDP) a resource certificate containing a Key Usage extension composed of more than two bytes of data. Fort writes this string into a 2-byte buffer without properly sanitizing its length, leading to a buffer overflow.