Skip to main content
VulnerabilityPublished Updated

CVE-2024-45614: puma · Insecure Direct Object Reference

Affects pumaSource GCVE Database

0
Compare

Not known to be exploited · CVSS 5.4 Medium : upgrade to 6.4.3 or 5.6.9 when convenient.

Data as of 30 Oct 2026, 02:22 UTC

CVSS 3.1 base score
5.4Medium
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (GitHub_M)CVSS 3.15.4
Patch
Available – fixed in 6.4.3, 5.6.9
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:L/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 19 Sep 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade puma to 6.4.3 or 5.6.9.

Affected software

ProductAffectedFixed in
puma pumaAffected
  • >=6.0.0 <6.4.3
  • <5.6.9
Fixed in
  • 6.4.3
  • 5.6.9

AI-suggested

Upgrade Puma to version 6.4.3 or 5.6.9 or later, where the vulnerability is fixed by discarding underscore headers when the non-underscore version exists. Until upgraded, users should not implicitly trust proxy-set headers for security decisions. Additionally, if using Nginx as a proxy, enable the underscores_in_headers configuration to discard headers containing underscores as a temporary mitigation.

Description

CVE-2024-45614 is an authorization bypass vulnerability in the Puma Ruby/Rack web server. Affected versions allow clients to override proxy-set headers (like X-Forwarded-For) by sending underscore variants (e.g., X-Forwarded_For). This can lead to trusting manipulated headers instead of those set by trusted proxies. Versions 6.4.3 and 5.6.9 fix this by discarding headers with underscores when the non-underscore version exists. Users relying on proxy headers for security should upgrade immediately or use proxy-level mitigations such as Nginx's underscores_in_headers setting.

References

Community reviews

Loading reviews…