Skip to main content
VulnerabilityPublished Updated

CVE-2024-46814: Linux kernel · drm/amd/display: Check msg_id before processing transcation

Affects Linux kernelSource GCVE Database

0

Not known to be exploited · CVSS 7.8 High · fixed in 5.15.0-1072.78~20.04.1 : patch Linux kernel soon.

Data as of 26 Oct 2026, 23:57 UTC

CVSS 3.1 base score
7.8High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 5.15.0-1072.78~20.04.1, 5.15.0-1078.87~20.04.1, 5.15.0-1071.79~20.04.1 +52
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 27 Sep 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
Ubuntu 24.04 LTSlinuxpkg:deb/ubuntu/linux?arch=source&distro=nobleOther threatsAffected
  • <6.8.0-50.51
Fixed in
  • 6.8.0-50.51
Ubuntu 24.04 LTSlinux-awspkg:deb/ubuntu/linux-aws?arch=source&distro=nobleOther threatsAffected
  • <6.8.0-1020.22
Fixed in
  • 6.8.0-1020.22
Ubuntu 24.04 LTSlinux-azurepkg:deb/ubuntu/linux-azure?arch=source&distro=nobleOther threatsAffected
  • <6.8.0-1020.23
Fixed in
  • 6.8.0-1020.23
Ubuntu 24.04 LTSlinux-gcppkg:deb/ubuntu/linux-gcp?arch=source&distro=nobleOther threatsAffected
  • <6.8.0-1019.21
Fixed in
  • 6.8.0-1019.21
Ubuntu 24.04 LTSlinux-gkepkg:deb/ubuntu/linux-gke?arch=source&distro=nobleOther threatsAffected
  • <6.8.0-1015.19
Fixed in
  • 6.8.0-1015.19
Ubuntu 24.04 LTSlinux-gkeoppkg:deb/ubuntu/linux-gkeop?arch=source&distro=nobleOther threatsAffected
  • <6.8.0-1002.4
Fixed in
  • 6.8.0-1002.4

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and should be applied by upgrading to one of the fixed Linux kernel versions 5.15.0-1072.78~20.04.1 or later as listed in the established facts. Users should update their Linux kernel packages to these fixed versions to remediate the vulnerability. No additional mitigation is required beyond applying the official fix.

Description

CVE-2024-46814 is a vulnerability in the Linux kernel's AMD display driver subsystem where the message ID (msg_id) was not properly checked before processing transactions. Specifically, the invalid HDCP_MESSAGE_ID_INVALID (-1) was used without validation, leading to four buffer overrun issues. This flaw has been fixed in multiple Linux kernel versions starting from 5.15.0-1072.78~20.04.1 and later. The vulnerability has a high severity score and could lead to confidentiality, integrity, and availability impacts if exploited.

References

Community reviews

Loading reviews…