Skip to main content
VulnerabilityPublished Updated

CVE-2024-46815: Linux kernel · drm/amd/display: Check num_valid_sets before accessing reader_wm_sets[]

Affects Linux kernelSource GCVE Database

0

Not known to be exploited · CVSS 7.8 High · fixed in 5.4.0-1135.145~18.04.1 : patch Linux kernel soon.

Data as of 26 Oct 2026, 23:57 UTC

CVSS 3.1 base score
7.8High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 5.4.0-1135.145~18.04.1, 5.4.0-1140.147~18.04.1, 5.4.0-1139.148~18.04.1 +75
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 27 Sep 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
Ubuntu 24.04 LTSlinuxpkg:deb/ubuntu/linux?arch=source&distro=nobleOther threatsAffected
  • <6.8.0-50.51
Fixed in
  • 6.8.0-50.51
Ubuntu 24.04 LTSlinux-awspkg:deb/ubuntu/linux-aws?arch=source&distro=nobleOther threatsAffected
  • <6.8.0-1020.22
Fixed in
  • 6.8.0-1020.22
Ubuntu 24.04 LTSlinux-azurepkg:deb/ubuntu/linux-azure?arch=source&distro=nobleOther threatsAffected
  • <6.8.0-1020.23
Fixed in
  • 6.8.0-1020.23
Ubuntu 24.04 LTSlinux-gcppkg:deb/ubuntu/linux-gcp?arch=source&distro=nobleOther threatsAffected
  • <6.8.0-1019.21
Fixed in
  • 6.8.0-1019.21
Ubuntu 24.04 LTSlinux-gkepkg:deb/ubuntu/linux-gke?arch=source&distro=nobleOther threatsAffected
  • <6.8.0-1015.19
Fixed in
  • 6.8.0-1015.19
Ubuntu 24.04 LTSlinux-gkeoppkg:deb/ubuntu/linux-gkeop?arch=source&distro=nobleOther threatsAffected
  • <6.8.0-1002.4
Fixed in
  • 6.8.0-1002.4

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and has been released by Ubuntu for affected kernel versions. Users should update their Linux kernel packages to the fixed versions listed in the advisory (e.g., 5.4.0-1135.145~18.04.1 and later). Applying these official updates will remediate the vulnerability. No additional mitigation steps are required beyond applying the vendor-provided fixes.

Description

CVE-2024-46815 is a high-severity vulnerability in the Linux kernel's AMD display driver subsystem. It involves improper validation of the num_valid_sets variable before accessing the reader_wm_sets array, which could lead to an out-of-bounds access. This flaw was identified and fixed to prevent potential memory overrun issues. The vulnerability affects multiple specific Linux kernel versions, primarily in the 5.4 and 4.11 to 4.13 series on Ubuntu 18.04 LTS and related distributions.

References

Community reviews

Loading reviews…