Skip to main content
VulnerabilityPublished Updated

CVE-2024-47191: oath-toolkit · Path Traversal

Affects oath-toolkitSource CVE Database V5

0

Not known to be exploited · CVSS 7.1 High · fixed in 2.6.12 : patch oath-toolkit soon.

Data as of 26 Oct 2026, 12:29 UTC

CVSS 3.1 base score
7.1High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 27% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.6.12
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 9 Oct 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
GitHuboath-toolkit/oath-toolkitpkg:github/oath-toolkit/oath-toolkitOther threatsAffected
  • >=2.6.7 <=2.6.11
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

To mitigate CVE-2024-47191, organizations should immediately upgrade oath-toolkit to version 2.6.12 or later, where the vulnerability is fixed. In environments where immediate upgrade is not feasible, administrators should audit and restrict local user privileges to minimize the risk of exploitation. Implement strict file system permissions and monitor for suspicious symlink creation or unauthorized file ownership changes, especially in directories used by pam_oath.so. Employ file integrity monitoring to detect unexpected changes to authentication-related files. Additionally, consider isolating or sandboxing authentication modules where possible to limit the impact of privilege escalation. Regularly review PAM configurations to ensure minimal exposure and avoid unnecessary use of vulnerable modules. Finally, maintain comprehensive logging and alerting on authentication events and privilege escalations to detect potential exploitation attempts early.

Description

pam_oath.so in oath-toolkit 2.6.7 through 2.6.11 before 2.6.12 allows root privilege escalation because, in the context of PAM code running as root, it mishandles usersfile access, such as by calling fchown in the presence of a symlink.

References

Community reviews

Loading reviews…