CVE-2024-47477: Dell PowerFlex Manager · Improper Certificate Validation
Affects Dell PowerFlex ManagerSource CVE Database V5
Not known to be exploited · CVSS 6.5 Medium : upgrade to 5.1.0.1 or later or 4.5.5.2 or later when convenient.
Data as of 30 Oct 2026, 20:25 UTC
- EPSS
- 0.1% chance of exploitation in 30 days – higher than 2% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 5.1.0.1 or later, 4.5.5.2 or later
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:NExploitation evidence
Disclosed: evidence found.
CVE published 17 Jun 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade Dell PowerFlex Manager to 5.1.0.1 or later or 4.5.5.2 or later.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| DellPowerFlex Manager | Affected
| Fixed in
|
Description
Dell PowerFlex Manager versions prior to 4.5.1.1 have an improper certificate validation vulnerability (CWE-295). This flaw could allow a remote unauthenticated attacker to perform a man-in-the-middle attack when combined with DNS cache poisoning. The vulnerability has a CVSS score of 6.5, indicating a medium severity level.