CVE-2024-47541: gstreamer · Out-of-bounds Write
Affects gstreamerSource GCVE Database
Not known to be exploited · CVSS 6.9 Medium : upgrade to 1.24.10 when convenient.
Data as of 30 Oct 2026, 02:23 UTC
Thin evidence
One scorer or none| CNA (GitHub_M) | CVSS 4.0 | 6.9 |
|---|
- Patch
- Available – fixed in 1.24.10
CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 11 Dec 2024
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade gstreamer to 1.24.10.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| gstreamer gstreamer | Affected
| Fixed in
|
AI-suggested
Upgrade GStreamer to version 1.24.10 or later, where this vulnerability is fixed. No other mitigation or workaround is indicated.
Description
CVE-2024-47541 is an out-of-bounds write vulnerability in GStreamer's gst_ssa_parse_remove_override_codes function, which parses SSA style override codes. The flaw occurs when a closing curly bracket appears before an opening one, causing memmove() to write beyond allocated memory. This issue is fixed in version 1.24.10.
References
- securitylab.github.com/advisories/GHSL-2024-228_GStreamer/ (opens in a new tab)
- gitlab.freedesktop.org/gstreamer/gstreamer/-/merge_requests/8036.patch (opens in a new tab)
- gstreamer.freedesktop.org/security/sa-2024-0023.html (opens in a new tab)
- lists.debian.org/debian-lts-announce/2024/12/msg00021.html (opens in a new tab)